Índice+Corresp (PROCV mais eficiente!)

Oi Pessoal!

Neste post vou ensinar como a combinação das fórmulas ÍNDICE e CORRESP pode substituir a fórmula PROCV, fazendo buscas mais eficientes!

Essa combinação cria uma fórmula do tipo Procura e Referência, que é capaz de retornar resultados inclusive de células à esquerda da coluna onde efetuamos uma busca. O que não é possível com a PROCV, que só consegue mostrar valores de células à direita da coluna da busca.

Bom, primeiro vou explicar o funcionamento de cada uma das fórmulas separadamente, usando a tabela abaixo como exemplo.

Fórmula ÍNDICE

Retorna o valor da célula na interseção de uma linha com uma coluna em um dado intervalo de células.

Para a tabela acima, escrevendo a fórmula =ÍNDICE(A1:D5;2;3), obteremos como resultado o valor 31, correspondente a interseção da linha 2 com a coluna 3 dentro do range A1:D5.

Fórmula CORRESP

Retorna a posição de um item em uma determinada coluna.

Escrevendo a fórmula =CORRESP(“Débora”;B:B;0), o Excel mostrará o valor 4, correspondente a posição do nome Débora na coluna B.

Segue a composição da fórmula CORRESP para melhor entendimento.

Corresp(valor procurado; range de busca; tipo de correspondência)

Valor procurado: Débora

Range de busca: B:B

Tipo de correspondência: (no caso que estamos estudando sempre usaremos 0)

0 – correspondência exata

1 – é maior do que

-1 – é menor do que

Agora, vamos ver como funciona a combinação dessas fórmulas.

Como exemplo, devemos escrever a seguinte expressão para encontrar a idade da Débora:

=ÍNDICE(A1:D5;CORRESP(“Débora“;B:B;0);3).

Nesta expressão, estamos pedindo ao Excel que mostre o valor da terceira coluna do range A1:D5, quando encontrar o nome Débora na coluna B. Como resultado obteremos o valor 29.

É claro que obteríamos o mesmo resultado com a fórmula PROCV, escrevendo: =PROCV(“Débora”;B2:C5;2;0), mas se quiséssemos encontrar algum valor da coluna A, anterior a coluna de busca (coluna B), não seria possível usando a PROCV.

Aqui entra a substituição da PROCV para fazermos buscas mais eficientes…

Conforme falei no início do post, diferentemente da PROCV, a combinação ÍNDICE + CORRESP consegue mostra como resultado valores contidos em colunas à esquerda da coluna onde estamos efetuando a busca.

Assim, na mesma tabela, podemos obter o valor da coluna A relacionado ao nome Débora. Para isso, basta escrever a seguinte expressão:

=ÍNDICE(A1:D5;CORRESP(“Débora”;B:B;0);1)

Reparem que apenas trocando o 3 pelo 1 no final da expressão (coluna de referência do resultado desejado), teremos Ciências Sociais como resultado!

Abs, Dr. E

P.S. Gostaria de pedir desculpas, mas infelizmente não estou conseguindo responder todos os e-mails com dúvidas que venho recebendo. Por isso, peço que não usem o espaço de comentários do post para enviar dúvidas.

PROCV – dicas_01

Oi Galera,

Resolvi escrever esse post para dar algumas dicas sobre a fórmula procv.

Vamos lá.

Dica 1 – No início, quando comecei a usar a procv, aconteceu de a fórmula não encontrar um registro qualquer, mesmo tendo certeza que, pelo menos visualmente, o respectivo registro encontrava-se no range da busca. Bom, mais tarde acabei descobrindo que temos que tomar muito cuidado com a formação das células onde estamos trabalhando. Principalmente quando falamos de campos numéricos, pois é vital que o registro procurado tenha a mesma formatação do range de referência da fórmula para que o excel identifique a equivalência entre os valores e mostre o resultado corretamente.

Dica 2 – a procv finaliza a busca assim que encontra a primeira ocorrência do registro procurado no range de referência. Então, quando quisermos obter como resultado a soma dos valores de um determinado registro que aparece repetidas vezes em um intervalo qualquuer de células, sugiro utilizar a fórmula somase (veja posts sobre esta fórmula aqui no blog).

Dica 3 – A procv sempre efetua a busca na primeira coluna do range selecionado, só sendo capaz de mostrar como resultado células à direita desta coluna, conforme coluna de referência informada na fórmula. Isso quer dizer que: no exemplo de fórmula =procv(A2; B:D;2;0) o excel buscará o valor da célula A2 no range B:D, trazendo como resultado o valor da coluna C (coluna 2 a contar da coluna B) relacionado ao valor de A2.

Bom, por enquanto esses são os pequenos detalhes que lembrei da fórmula procv que nos dão o maior trabalho quando surgem. Lembrando que mais algum ponto, prometo incluir um novo post de título PROCV – Dicas_02.

Abs, Dr. E

P.S. Gostaria de pedir desculpas, mas infelizmente não estou conseguindo responder todos os e-mails com dúvidas que venho recebendo. Por isso, peço que não usem o espaço de comentários do post para enviar dúvidas.

PROCV – parte_01

Oi Pessoal!

Neste primeiro post, vou ensinar como usar a função procv do Excel (ou vlookup na versão em inglês do software) para encontrar um determinado registro em uma lista específica (coluna do Excel).

Veja a imagem abaixo que contém uma lista de nomes na coluna A. A ideia é verificar se o nome “Rodrigo” aparece alguma vez nessa lista. Para isso, vamos usar a fórmula mostrada na célula C2 da figura abaixo, em amarelo.

Se o nome “Rodrigo” for encontrado na lista da coluna A o Excel retornará Rodrigo como resultado na célula C2, não encontrando retornará #N/D.

Sobre os campos da fórmula acima: =PROCV(“Rodrigo”;A1:A12;1;0)

“Rodrigo” – registro que desejamos encontrar em uma determinada lista.

A1:A12 – intervalo de células (range) que contém a lista onde estamos efetuando a busca.

1 – campo de referência (coluna) do resultado que queremos encontrar. (melhor compreendido nos próximos exemplos a seguir).  Continua no próximo post…

Abs, Dr. E

P.S. Gostaria de pedir desculpas, mas infelizmente não estou conseguindo responder todos os e-mails com dúvidas que venho recebendo. Por isso, peço que não usem o espaço de comentários do post para enviar dúvidas.

PROCV – parte_02

Dando continuidade ao post Fórmula PROCV no Excel – parte 01 vou dar um exemplo com um intervalo de células (range) maior para facilitar o entendimento do campo de referência que citei anteriormente.

Observe na figura abaixo que incluí mais uma coluna na tabela (coluna Idade) e que alterei o campo de referência da fórmula para 2. Desta forma, estou solicitando ao Excel que retorne o registro da segunda coluna do range correspondente ao nome “Rodrigo”, caso este seja encontrado na lista (coluna A). Assim, o Excel mostrará 26 como resultado.

Outras alterações que efetuei na fórmula foram: troquei o nome “Rodrigo” pela célula D1, cujo valor é Rodrigo, retirei as referências de linhas (início e término) do range onde estamos efetuando a busca e incluí a coluna B neste range , ou seja, o range anterior A1:A12 agora corresponde ao range A:B. Isso torna a fórmula mais inteligente, possibilitando a inclusão de novos nomes na lista (a partir da linha 12) sem que precisemos alterar a fórmula.

Abs, Dr. E

P.S. Gostaria de pedir desculpas, mas infelizmente não estou conseguindo responder todos os e-mails com dúvidas que venho recebendo. Por isso, peço que não usem o espaço de comentários do post para enviar dúvidas.