Índice+Corresp (PROCV mais eficiente!)

Oi Pessoal!

Neste post vou ensinar como a combinação das fórmulas ÍNDICE e CORRESP pode substituir a fórmula PROCV, fazendo buscas mais eficientes!

Essa combinação cria uma fórmula do tipo Procura e Referência, que é capaz de retornar resultados inclusive de células à esquerda da coluna onde efetuamos uma busca. O que não é possível com a PROCV, que só consegue mostrar valores de células à direita da coluna da busca.

Bom, primeiro vou explicar o funcionamento de cada uma das fórmulas separadamente, usando a tabela abaixo como exemplo.

Fórmula ÍNDICE

Retorna o valor da célula na interseção de uma linha com uma coluna em um dado intervalo de células.

Para a tabela acima, escrevendo a fórmula =ÍNDICE(A1:D5;2;3), obteremos como resultado o valor 31, correspondente a interseção da linha 2 com a coluna 3 dentro do range A1:D5.

Fórmula CORRESP

Retorna a posição de um item em uma determinada coluna.

Escrevendo a fórmula =CORRESP(“Débora”;B:B;0), o Excel mostrará o valor 4, correspondente a posição do nome Débora na coluna B.

Segue a composição da fórmula CORRESP para melhor entendimento.

Corresp(valor procurado; range de busca; tipo de correspondência)

Valor procurado: Débora

Range de busca: B:B

Tipo de correspondência: (no caso que estamos estudando sempre usaremos 0)

0 – correspondência exata

1 – é maior do que

-1 – é menor do que

Agora, vamos ver como funciona a combinação dessas fórmulas.

Como exemplo, devemos escrever a seguinte expressão para encontrar a idade da Débora:

=ÍNDICE(A1:D5;CORRESP(“Débora“;B:B;0);3).

Nesta expressão, estamos pedindo ao Excel que mostre o valor da terceira coluna do range A1:D5, quando encontrar o nome Débora na coluna B. Como resultado obteremos o valor 29.

É claro que obteríamos o mesmo resultado com a fórmula PROCV, escrevendo: =PROCV(“Débora”;B2:C5;2;0), mas se quiséssemos encontrar algum valor da coluna A, anterior a coluna de busca (coluna B), não seria possível usando a PROCV.

Aqui entra a substituição da PROCV para fazermos buscas mais eficientes…

Conforme falei no início do post, diferentemente da PROCV, a combinação ÍNDICE + CORRESP consegue mostra como resultado valores contidos em colunas à esquerda da coluna onde estamos efetuando a busca.

Assim, na mesma tabela, podemos obter o valor da coluna A relacionado ao nome Débora. Para isso, basta escrever a seguinte expressão:

=ÍNDICE(A1:D5;CORRESP(“Débora”;B:B;0);1)

Reparem que apenas trocando o 3 pelo 1 no final da expressão (coluna de referência do resultado desejado), teremos Ciências Sociais como resultado!

Abs, Dr. E

P.S. Gostaria de pedir desculpas, mas infelizmente não estou conseguindo responder todos os e-mails com dúvidas que venho recebendo. Por isso, peço que não usem o espaço de comentários do post para enviar dúvidas.

About these ads

9 Respostas

  1. Sem dúvida utilizar Índice e Corresp no lugar do ProcV deixa a planilha mais leve. Uma outra solução que seria mais leve ainda, é utilizar a fórmula “Indireto” ao invés do Corresp.

    O “Indireto” é uma fórmula altamente subestimada no reino Exceliano. Durante anos ela foi incompreendida e abandonada, deixada para o final (quando ao menos mencionada!) nos cursos e bibliografias a respeito do assunto.

    Faça parte do movimento: “Tudo fica certo quando se usa o indireto”

    • Ovelha, obrigado pelo comentário!

      Não conhecia a fórmula “Indireto”. Acho que o maior benefício deste blog será o aprendizado de novas dicas e truques!

  2. Muito boa essa dica. Nunca fiz assim!!!

    Valeu!

  3. Muito boa dica! Abs

  4. A combinação do índice + corresp é violento mesmo. Eu uso muito também desloc + corresp. Muito show de bola

  5. Obrigado pela dica! Realmente a combinação índice + corresp deixa a buca bem mais eficiente!

    Abs.

    Ewerton.

  6. Obrigado pela dica! Realmente a combinação índice + corresp deixa a busca bem mais eficiente!

    Abs.

    Ewerton.

  7. Parabens! Sua sugestao foi perfeita para minha planilha, minhas planilhas estao muito mais leves e atualizam super rapido. FANTASTICO!

  8. Com toda a certeza é muito importante conhecer e saber utilizar as funções de pesquisa no excel visto que sao muito utilizadas no ambito empresarial. Muito boa a sua abordagem sobre esta função.

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Seguir

Obtenha todo post novo entregue na sua caixa de entrada.

Junte-se a 28 outros seguidores